Skocz do zawartości
pablo

tclTempMonitor - sugestie, uwagi

Rekomendowane odpowiedzi

W dziale pliki umieściłem pierwszą wersję programu tclTempMonitor

https://www.piwo.org/files/file/31-tcltempmonitor/

 

Tutaj proszę o zgłaszanie wszelkich pytań, sugestii i uwag.

 

Ciekawe, komu pierwszemu uda się uruchomić ;)

.

Edytowane przez pablo

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Cześć ;-)

Nie działa pod windows ;-)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nie działa pod windows ;-)

Ale może. Potrzeba tylko śmiałka, który skompiluje owfs na Windows (chyba w cygwin)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

O proszę :) Super Pablo! Dzisiaj nie mam jak potestować, ale w środę myślę jakiegoś starego pc do browaru dołożyć, to dam znać jak się sprawuje.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Brawo! A działa 11.04 i starszych? Jestem cienki na linuxie :/

Edit

Czy kompilacja jest taka sama?

Edytowane przez Jejski

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kompilacja OWFS taka sama.

Będzie działać na 11.04 też (a przynajmniej docelowo ;) )

W razie problemów pisz - pomogę.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Odpaliłem na szybko, bo nie wytrzymałem i wygląda na to, że działa :) Co prawda po 2-3 sekundach się zamyka, ale wynika to ewidentnie z braku czujników i konfiguracji ows.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Znalazłem chwilkę i nieco podciągnąłem program.

Z najważniejszych zmian:

  • wszystko konfigurowane z poziomu użytkownika
  • dodawanie czujników

Nowa wersja w plikach. W opisie linki do dokumentacji która będzie na bieżąco aktualizowana.

 

Czy ktoś ma doświadczenie w kompilacji aplikacji linuxowych na widowsach (cygwin, migwin)? OWFS powinno ładnie dać się skompilować i działać.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Próbowałem skompilować pod cygwinem owfs ale to nie będzie prosta i szybka sprawa. Po godzinnej walce chyba się zacznę poddawać.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kompilacja OWFS taka sama.

Będzie działać na 11.04 też (a przynajmniej docelowo ;) )

W razie problemów pisz - pomogę.

Proszę o pomoc dla lamera w instalacji OWFS 11.04 , z konsoli korzystam bardzo rzadko, choć z ubuntu chyba od wersji 6.0

Cały problem jak mi się wydaje to dodanie odpowiedniego repo bo po

sudo apt-get install \
automake autoconf autotools-dev gcc g++ \
libtool libusb-dev fuse-utils libfuse-dev \
swig python2.4-dev tcl8.4-dev php5-dev

dostaję

E: Nie udało się odnaleźć pakietu python2.4-dev
E: Couldn't find any package by regex 'python2.4-dev'

Czyli wychodzi że mam nowszą wersję a OWFS potrzebuje 2.4 ?

Jeśli dobrze myślę co powinienem dodać do sources.list by

Odśwież listę pakietów
sudo apt-get update

i zobaczyć

Zobacz listę dostępnych pakietów związanych z owfs
	 apt-cache search owfs

Piszę tu a nie na PW bo może się komuś jeszcze to przyda.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pablo, ja się nie znam, więc pytanie może być nie za mądre. A dla uproszczenia instalacji nie da się zaprząc digitempa ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

# Ubuntu - podstawowe repozytoria

deb http://pl.archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse

deb http://pl.archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse

deb-src http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse

deb http://extras.ubuntu.com/ubuntu natty main

deb-src http://extras.ubuntu.com/ubuntu natty main

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pablo, ja się nie znam, więc pytanie może być nie za mądre. A dla uproszczenia instalacji nie da się zaprząc digitempa ?

Rozpoznam temat digitempa. Nadzieja jest w tym, że w obecnych wydaniach *buntu jest dostępna jako pakiet (co prawda obecna wersja u mnie nie działa :/ ale kolejne powinny ;)

 

Jejski. Aktualna instrukcja kompilacji OWFS w instrukcji (link w opisie pliku programu. Tam nie ma pzthon2.4+dev ;)

edit1:(wiki doczeka się aktualizacji - odnośnika do strony OWFS :D )

edit2:(na wiki wyraźnie pisze że instrukcja dotyczy Ubuntu 10.10 - nie łapiesz się)

Edytowane przez pablo

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Robię według opisu ze strony http://owfs.org/inde...ng-under-ubuntu i mam taki problem przy

make -j4

libtool: Version mismatch error. This is libtool 2.4 Debian-2.4-2ubuntu1, but the

libtool: definition of this LT_INIT comes from libtool 2.2.6b.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4 Debian-2.4-2ubuntu1

libtool: and run autoconf again.

make[4]: *** [owget] Błąd 63

Ratunku :|

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Może to nie ma zwiazku, ale zrób wszystko jeszcze raz dokładnie ( pobierz źródła z sourceforga a Nie przez csv) wg mojej instrukcji.

 

Daj znać.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Już mi ręce opadają. :roll:

pobierz źródła z sourceforga a Nie przez csv

To znaczy jak? Łopatologicznie proszę.

wg mojej instrukcji.

Przypominam że mam 11.04 a Twoja instrukcja dotyczy 12.04

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pablo, ja się nie znam, więc pytanie może być nie za mądre. A dla uproszczenia instalacji nie da się zaprząc digitempa ?

Zaprzągłem. Nowa wersja do pobrania.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Fajnie tylko u mnie jak zwykle problem :monster: .

jejski@jejski-laptop:~/tclTempMonitor1.0.3-a$ ./main.tcl
Error in startup script: can't find package ow
while executing
"package require ow"
(file "ow.tcl" line 8)
invoked from within
"source ow.tcl"
(file "./main.tcl" line 18)
jejski@jejski-laptop:~/tclTempMonitor1.0.3-a$

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

pablo jesteś WIELKI! :okey: 1.0.4 z digitemp działa dzięki. Po południu robię kapilary na rurce CU i jutro montaż we warzelni.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Robię według opisu ze strony http://owfs.org/inde...ng-under-ubuntu i mam taki problem przy
 make -j4 

libtool: Version mismatch error. This is libtool 2.4 Debian-2.4-2ubuntu1, but the libtool: definition of this LT_INIT comes from libtool 2.2.6b. libtool: You should recreate aclocal.m4 with macros from libtool 2.4 Debian-2.4-2ubuntu1 libtool: and run autoconf again. make[4]: *** [owget] Błąd 63 Ratunku :|

Spróbuj zamiast

autoreconf -i

polecenie

autoreconf -i --force

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

pablo jesteś WIELKI! :okey: 1.0.4 z digitemp działa dzięki. Po południu robię kapilary na rurce CU i jutro montaż we warzelni.

Liczę, że pochwalisz się efektami :beer:

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

×