Jump to content
anatom

PID - błędny odczyt temperatury

Recommended Posts

Czołem, używam PID z MyPIN model TA4. Do niego podłączony czujnik temperatury PT100. 

Problem jest taki że mocno rozjeżdża się temperatura pomiaru z tą jaka jest rzeczywiście. 

W temperaturze pokojowej zawyża o ok 3C. Przy temperaturach zacierania rozjeżdża się już o ok 6C. Widać że zakres tolerancji ma ok 10% to jest zbyt dużo. Dokumentacja TA4 pokazuje że dokładność  wynosi 0,2%. Czujnik PT100 klasa B dokładność według dokumentacji w granicach +- 0,5C. 

W czym może być problem? 

Share this post


Link to post
Share on other sites

Ciężko powiedzieć. Na kablu nie ma info, a nie mam żadnej dokumentacji. Kupiony był cały zestaw: czujnik sonda i kabel. 

https://s.click.aliexpress.com/e/mORAWc4C

 

Przy czujniku jest wejście 3PIN a do sterownika są wejścia 4 pinowe. Może tutaj trzeba pokombinować. Nie jest tak że jakby było źle podłączone to by wcale nie działało? 

 

Share this post


Link to post
Share on other sites

Używam takiego samego czujnika ale mam inny PID. Może w ustawieniach masz możliwość korekcji temperatury? Zmierz jaka ma oporność czujnik przy 20°C

(Jak masz możliwość to przy 100°C będzie łatwiej)

 

Share this post


Link to post
Share on other sites

Kolego wygoogluj sobie tabele oporności pt100 i porównaj wartości. Żeby potwierdzić błąd musisz mieć wiarygodny pomiar. Najlepiej by było jakbyś miał 3 czujniki temperatury albo termometry i wszystkie włożył do lodówki na 1h i dokonał pomiaru z czujnikiem w lodówce. 2 pomiary temperatury jako referencyjne wartości a PT100 mierzysz pod kątem oporności i porównaj wynik z tabelą.

https://images.app.goo.gl/DALVowQXAxSBVbu49

Share this post


Link to post
Share on other sites

Poodpinalem wszystko i powpinalem od nowa. Wymieniłem też pt100. Co prawda dalej pokazują +3C za wysoko ale skalibrowalem je z dwoma innymi termometrami w 22C i na szczęście w 70C wskazują prawidłowo. Nie rozjezdza się o te 10% jak wcześniej. 

Tak że dzięki. Mogę zacierać😃

 

P. S jakie masz Pidy jeśli można spytać? Co myślisz o tych z Mypin z aliexpres? 

Share this post


Link to post
Share on other sites

Może to wynikać z tego że to po prostu tanie Chiny, nie ubliżając oczywiście:) ale może da się skompensować w jakiś sposób te 3°C bo to dziwne że w wyższych temperaturach wskazuje prawidłowo... Chociaż nie... Bo PT100 pracuje liniowo... Obstawiam że to wina PIDa...

 

Ja mam Omron E5CC RX3A5M

 

Edyta:

A jak podpiales PT100? Możesz zdjęcie wysłać?

Share this post


Link to post
Share on other sites
46 minut temu, Robert87 napisał:

ale może da się skompensować w jakiś sposób te 3°C bo to dziwne że w wyższych temperaturach wskazuje prawidłowo...

Po kalibracji w 22C wskazuje prawidłowo w każdej temperaturze więc jest ok. Wcześniej miałem tak że po skalibrowaniu w ok 20C rozjezdzal się przy temp ok 70C i odwrotnie - jak skalibrowalem w 70C to źle wskazywał w temp pokojowej. 

Wymieniłem pt100, przeczyscilem gniazda itd i teraz po kalibracji w 22C wskazuję już dobrze w każdej temperaturze. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...