Jump to content

PID - ustawienia parametrów


anatom
 Share

Recommended Posts

Cześć,

może mnie ktoś nakierować jak dobrać parametry P, I, D w MyPIN TA4 i TD4 żeby sterownik uwzględniał bezwładność cieplną garów?

Na razie ustawienia P, I, D mam na off, gar 100L, grzałka 5,5 kW.

Zadaję np 50C PID wyłącza się po osiągnięciu 50C ale temperatura jeszcze rośnie tak do 53, 54C (na próbce ok 15l wody). Trzeba pogrzebać w ustawieniach P, I i D tak żeby sterownik zaczął "zwalniać" w odpowiednim momencie. 

Pewnie macie doświadczenia, pomóżcie.

 

Link to comment
Share on other sites

 

 

 

 

Na razie ustawienia P, I, D mam na off ...

...PID wyłącza się po osiągnięciu 50C ale temperatura jeszcze rośnie tak do 53, 54C

 

 

To masz PID włączony czy nie? Jeśli nie to sterownik działa jak termostat. Spróbuj na włączonym trybie PID ustawić temperature i wtedy sprawdź czy jest ok, bo wg zasady działania samego PID nie powinien przegrzewać o 4°C

 

 

 

Link to comment
Share on other sites

Nie mam ustawionych algorytmów PID, są dane na off. Ustawienia tych algorytmów powinny spowodować że sterownik tak steruję mocą grzałki że w sam raz dochodzi do zadanej temperatury i grzałka nie przegrzewa. 

Link to comment
Share on other sites

Ustawiaj metodą prób i błędów, np co 1/4 zakresu, wlej wodę do gara i obserwuj. Ustaw sobie np 35°C (żeby było szybciej) i co zmiana parametrów wymieniaj wodę na zimna. Zaobserwuj przy jakich wartościach woda się grzeje stosunkowo szybko i nie przekracza temperatury zadanej. Zrób notatki

Link to comment
Share on other sites

  • 2 weeks later...

Po auto tuningu działa jak należy. 

 

Mam jeszcze jedno pytania. 

Jak w mypin TD4 ustawić poziom mocy grzałki? Chciałbym, po doprowadzenie do wrzenia, ustawić moc np na 70%. Chyba jest taka możliwość? 

Dziękuję 

 

Edit: dobra już wiem, Amerykanie pomogli niezwłocznie 

Edited by anatom
Link to comment
Share on other sites

Ok. Pozwolę sobie zacytować oryginalna wiadomość z forum. Nie sprawdzałem czy to działa bo nie warzyłem od tego czasu. Po następnej warce to potwierdzę. 

 

Just hit the set button (The current pwm percentage will show that its using in auto mode) and then hit and hold the green manual button for 3 seconds until the light comes on... Then use the blue arrow key to scroll to the digit you want to change to set your manual % value and hit set... Setting the temp is fairly easy hit the blue scroll arrow button to scroll to the digit you want to change than the up or down arrows to adjust the value and then hit "set" (yellow button.) The red (SV) digits are your desired temp set point or desired pwm % depending on the mode your in.

 

Potwierdzam: działa

Edited by anatom
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.