Jump to content

BrewPiLess - bardzo ekonomiczny kontroler fermentacji (wersja 02.03.2017)


Gwynbleidd
 Share

Recommended Posts

12 hours ago, marlow said:

Myślicie, że da się zrobić Brewpiless na takim zestawie:

- Sonoff basic i grzałka akwariowa (ESP+grzanie)

- iSpindel (temperatura+plato)

Oczywiście tylko grzanie bez chłodzenia.

 

???

Da się. Trzeba sprawdzić tylko piny w kodzie (zdaje się, że nawet jest przygotowana konfiguracja) i samemu skompilować kod.

 

Link to comment
Share on other sites

  • 3 weeks later...

Możecie podpowiedzieć jak dokładnie skonfigurować BPL z iSpidel?

Rozumiem, że jak wyłączę opcję: Calculated by BPL to BPL będzie pobierał gęstość z iSpindel.

Jeśli ta opcja będzie załączona to z iSpindel pobierane są tylko pochylanie i temperatura - gęstość jest liczona przez BPL.

Muszę zatem uzupełnić: Coefficients wpisując w  pierwsze pole 0 a dalej to co wyszło podczas kalibracji iSpindel?

Czy zadając autokalibrację na podstawie pomiarów pochylenia w wodzie i gęstości brzeczki współczynnik musi być wypełniony czy same zera?

Wojtek

Link to comment
Share on other sites

W dniu 27.03.2020 o 14:16, WojtekGaaD napisał:

Możecie podpowiedzieć jak dokładnie skonfigurować BPL z iSpidel?

Rozumiem, że jak wyłączę opcję: Calculated by BPL to BPL będzie pobierał gęstość z iSpindel.

Jeśli ta opcja będzie załączona to z iSpindel pobierane są tylko pochylanie i temperatura - gęstość jest liczona przez BPL.

Muszę zatem uzupełnić: Coefficients wpisując w  pierwsze pole 0 a dalej to co wyszło podczas kalibracji iSpindel?

Czy zadając autokalibrację na podstawie pomiarów pochylenia w wodzie i gęstości brzeczki współczynnik musi być wypełniony czy same zera?

Wojtek

 

Czołem, wczoraj właśnie stanąłem przed tym samym problemem i chyba się udało. Opcji "Coefficients" nie uzupełniałem i jej nie włączałem.

image.thumb.png.b283d12ad2cdb4b93517552ac768c95d.png 

Jak już uruchomiłem iSpindel i widziałem że przesyła dane do BPL, wrzuciłem go do fermentatora. Następnie uruchomiłem logowanie z opcją iSpidel i uzupełniłem jedynie kąt dla wody. W moim przypadku było to 23.4 stopnie. Kolejnym krokiem było dodanie OG i SG (trzeba uzupełnić oba inaczej mi nie działało) w zakładce "GRAPH" w celu ustawienia początkowej wartości gęstości i aktualnej. Uzupełniamy je klikając w miejsca które zaznaczyłem.

 

image.png.99af39d117d28914c27c5852a04aefc2.png

 

Na podstawie tych danych BPL wyznacza sobie liniowy wykres (na podstawie dwóch pomiarów, kąt w widzie i aktualny kąt dla podanej gęstości) który można podejrzeć, klikając w literkę "f" pod legendą:

 image.thumb.png.558954541af5ca45a8e2052238482d34.png

 

Z tego co czytałem można dodawać kolejne punkty pomiaru (SG, max 22 pomiary), wtedy wykres będzie bardziej dokładny i nie będzie już liniowy (chyba że tak będzie wynikać z pomiarów)

Link to comment
Share on other sites

  • 1 month later...

Cześć.

Może ktoś coś mi podpowie.

Mam w tej chwili na fermentacji dwie warki różniące się ekstraktem 14 i 17 blg (fermentacja juz się kończy). Jedna jest w beczce 35 l druga w beczce 60 l. Objętość brzeczek taka sama, grzałki użyte do podgrzewania takie same (80W). Sondy zanurzone mniej więcej na tą samą głębokość, beczki stoją w tym samym pomieszczeniu obok siebie. Wersja brewpiless w obu sterownikach tak sama.

Tu linki do wykresów:

https://thingspeak.com/channels/635898

https://thingspeak.com/channels/636871

 

Jedna jak wynika z wykresu ma wahania o 0,5°C, druga o 0,1°C.

Gdzie może być problem?

Link to comment
Share on other sites

może gdzieś grzałka jest bliżej sondy temperatury albo dalej i mocniej podgrzewa otoczenie, takie wahania to żaden raczej problem, poprawnie działające sterowanie powinno utrzymywać piwo w temperaturze +/- 0.1 od zadanej.

 

np moje teraz piwko co fermentuje (akurat na początku wykresu co trochę moja wina):

image.thumb.png.b7250b591f71159ea2305147ee519196.png

Link to comment
Share on other sites

  • 5 weeks later...

Ktoś podpowie gdzie podejrzeć dane jakie są wysyłane do Ubidots? Wczoraj przy konfiguracji gdy miałem podpięty tylko chamber temp. sensor to dane nie były wysyłane. Sytuacja zmieniła się jak z chamber temp zmieniłem na beer temp, wtedy Ubidots zaczął dane zbierać. 

Link to comment
Share on other sites

Czołem ekipo.

 

Dorobiłem się w końcu własnego brepiless, nastawiłem piwko w lodówce, podłączyłem wszystko i mam problem - otóż wygląda na to, że urządzenie zawiesza się co 24 h. Na wyświetlaczu pojawiają się krzaki. Można wejść na stronę brepiwless, ale wygląda jakby nastaw temperatury lodówki mocno się podnosił. Odłączenie od prądu i ponowne podłączenie naprawia problem na kolejne 24h. Macie może jakieś pomysły co może się dziać??

 

Screenshot_3.thumb.jpg.2b6363d83f1e0ded9083b7d6694fba49.jpg

Link to comment
Share on other sites

Najnowsza wersja? W niektorych wystepuje blad na wykresie ale program dziala normalnie, czy podczas tego masz takie same temperatury w tabelce i np w devices? Jezeli to nie to moze sondy tempertatury przerywaja czy szaleja lub sam esp sie zawiesza, pewnie masz podrobke esp a one moga miec jakies regulatory na plytce walniete, nie samo esp ale plytka na ktorej siedza bo nie wiem czy sa podrobki samych esp :)

 

Link to comment
Share on other sites

W dniu 10.06.2020 o 12:54, Gwynbleidd napisał:

Najnowsza wersja? W niektorych wystepuje blad na wykresie ale program dziala normalnie, czy podczas tego masz takie same temperatury w tabelce i np w devices? Jezeli to nie to moze sondy tempertatury przerywaja czy szaleja lub sam esp sie zawiesza, pewnie masz podrobke esp a one moga miec jakies regulatory na plytce walniete, nie samo esp ale plytka na ktorej siedza bo nie wiem czy sa podrobki samych esp :)

 

 

Już to rozkminiłem. Jadę na "beer constant" więc nastaw lodówki jest wynikiem działania algorytmu PID. Po restarcie urządzenia przyjmuje wartość zbliżoną do temperatury piwa i dopiero później się rozkręca. Jeżeli chodzi o krzaki na LCD to gadałem z Vito Tai i jest to znany bug. Teoretycznie LCD powinno się odświeżać co 10 minut i kasować te krzaki ale u mnie tak się nie dzieje. Olałem bo i tak w sumie nie korzystam z wyświetlacza. Przestawiłem LCD Auto off na 1 i teraz już krzaków nie widzę :)

Link to comment
Share on other sites

  • 4 months later...

żadna filizofia większa, sprawdzasz IP brewpiless, w iSpindel wpisujesz ten IP wraz z dopiskiem /gravity i tyle. Brewpiless jak odbierze dane to je wyswietli. Można zrobić też Access Pointa z brewpilessa i wysyłać na niego dane 192.168.4.1/gravity jeżeli np nie masz dostepu do wifi. Moze ispindel w srodku np lodowki nie ma dostepu do domowego wifi? Mi tak sie zdarzylo i wtedy korzystalem z AP

Link to comment
Share on other sites

 

W dniu 5.11.2020 o 13:40, szczawiosław napisał:

Pół dnia walczę aby połączyć BrewPiLess i iSpindel

Mi to pomogło, pola których nie opisałem chyba są oczywiste.

Poprawiłem opisy w tabelce poniżej wg. @Gwynbleidd myślę że teraz jest już dobrze, może komuś się przyda.

 

konfiguracja.png.3302ba35abb352e5ea39f242f5cfa75b.png

 

Edited by 330ml
Link to comment
Share on other sites

troche tu pomieszane, gora wskazuje na AP tryb bo wpisujesz siec brewpiless a dol gdzie wpisujesz IP wskazuje na router. To IP musi być z tej sieci z ktorej korzysta iSpindel czyli jak to jest domowa to IP brewpiless z sieci domowej, a jak siec brewpiless to IP wewnetrznej sieci AP brewpilessa czyli zazwyczaj 192.168.4.1

Link to comment
Share on other sites

Ten obrazek z jakiegoś niemieckiego forum, tylko z prawej strony moje opisy. Więc dla rozjaśnienia sprawy: 

1. Jeśli sieć domowa, to na dole adres który przydziela router,

2. Jeśli sieć Brewpiless, to na dole adres 192.168.4.1

Też miałem problemy z konfiguracją, wertowałem internet i ten obrazek trochę mi pomógł, ale nie do końca. Jak miałem ustawiony iSpindel na sieć domową to jakoś to działało, jak ustawiłem na sieć Brewpiless i adres z routera, to Brewpiless zaczął gubić sieć. Myślałem że to wina Wemos, że może płytka pada, jak tylko piwo dofermentuje zmienię te ustawienia i zabaczę czy problem zniknie. Cóż całe życie się uczymy i nawet rzeczy dla innych oczywiste mogą być problemem, @Gwynbleidd dzięki za czujność i poprawienie mojego błędu :)

Link to comment
Share on other sites

Dzisiaj nieźle się wku..rzyłem. Raz dziennie sprawdzam co się dzieje w lodówce, na BPL i fizycznie. Wczoraj sprawdzałem około g12. Dzisiaj też tylko że nie byłem zadowolony.

Po krótkim dochodzeniu widać, że wczoraj o 12.30 zamulił na 20 minut po czym jakby się przestawił o 3'C wyżej. W tym momencie jest już fermentacja z dupy. Piana poszła pod korek i piwo roku to nie będzie ale co robić żeby to się nie powtórzyło? Mieliście takie akcje?

Clipboard01.jpg

Clipboard02.jpg

Clipboard03.jpg

Link to comment
Share on other sites

Nie korzystałem jak dotąd z opcji schematu fermentacji. Jedyne problemy jakie miałem to gdy nagle odłączyły mi się czujki temperatury. To jednak była wina połączeń. Dotąd uzywalem wersji 3.5 i dzisiaj wystartowałem na wersji 4.01. Mam nadzieje że będzie działać jak należy.

Wysłane z mojego SM-G975F przy użyciu Tapatalka

Link to comment
Share on other sites

  • 3 months later...

Heja, może ktoś pomoże, tak się zdarzyło że mój brewpiless siedzi teraz w keezerze, ostatnio całkowicie z wygody przerzuciłem się na kveiki a lodówka fermentacyjna skończyła jako keezer. Mam podpięty licznik energii, w puszce mam zasilacz na 12v, pozniej buck z 12v na 5v i podpięte do ESP, plus jeszcze podwójny moduł relay. Jeżeli lodówka nie chodzi to pokazuje mi zużycie 0A i 0W, więc bardzo mało tak że zaokrągla do zera. Ostatnio dołożyłem wentylator bo miałem problemy aby była równomierna temperatura w lodówce, piwo w przewodach robiło się ciepłe, podpiąłem go pod zasilacz gdzie jest 12V i chodzi 24h na dobę. Zużycie podskoczyło do 4W co jest dość sporym zyżyciem biorąc pod uwagę że to tylko wiatrak działa a on nie powinien przy 12v pobierać więcej jak 200mA więc skąd te 4W? Do dupy sprawność zasilacza? Coś nie tak z wiatrakiem?

Link to comment
Share on other sites

Moc czynna to napięcie razy natężenie w Twoim przypadku w warunkach idealnych to 0,2A x 12V = 2,4VA.  Kiedyś robiłem generator dymu wędzarniczego do którego użyłem wentylatorka od procka. Na działce nie miałem prądu, postanowiłem użyć akumulatora. Dobierając wentylator korzystałem z zasilacza komputerowego. Znalazłem i użyłem taki wentylator, który pobierał 172mA mimo że na etykiecie miał 140mA. Na działce z akumulatora brał 150mA przy napięciu 12,8V. Z zasilacza masz prąd niby stały, przetwornica chodzi z częstotliwością 40kHz i prąd ma jakąś składową zmienną to ona może powodować wzrost poboru mocy. Jeżeli Twój zasilacz jest transformatorowy to masz pulsowanie 100Hz to też będzie miało wpływ na moc. Zpomiary przy zasilaniu z akumulatora wtedy będziesz znał prawdziwą wartość mocy.

Edited by mirek1g
Link to comment
Share on other sites

jak podłączam do zasilacza laboratoryjnego pod 12V to widzę że jest 100mA około po rozruchu już. Także to nie dużo, a wzrost mocy z prawie 0W do 4W na 230V (to trochę ponad 40mA) to jest dość sporo. Zasilacz powinien być bardziej sprawny przy wyższym obciążeniu, to gdzie ta moc się podziewa którą pobiera zasilacz? Na wentylator nie idzie bo on tyle nie bierze, rozumiem że są straty ciepła na zasilaczu ale aż tyle? Zwłaszcza że bez wentylatora z samym ESP jest to wartość zbliżona do 0W/0A?

Edited by Gwynbleidd
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.